Contact Us | Site Map
Firebird is used by approximately 1 million of software developers worldwide. High compatibility with industry standards on many fronts makes Firebird the obvious choice for developing interoperable applications for homogeneous and hybrid environments.
April 06, 2019
More News
Jaybird 2.2.15 released

We are happy to announce the release of Jaybird 2.2.15.

Jaybird 2.2.15 is the last version of Jaybird 2.2.x, and we will not plan new changes or fixes for 2.2.x. This effectively means that Jaybird 2.2.x is End-Of-Life.

If you run into problems, we will recommend that you switch to Jaybird 3 (or 4 once it is released). Contact us on Firebird-Java for questions.

Jaybird 2.2.15 contains the following fixes and changes:

  • Fixed: Exceptions during fetch of cached result sets (holdable over commit, scrollable and metadata) prevented prepared statement reuse/re-execute with error _"Attempt to reopen an open cursor"_ JDBC-531)
  • Fixed: Jaybird cannot parse Firebird version numbers with revisions (JDBC-534)
  • Fixed: Incorrect parsing of Firebird version numbers (JDBC-535)
Jaybird 2.2 supports Firebird 1.0 and higher, on Java 6, 7 and 8. For Java 11 or higher, use Jaybird 3.

See also:

Join Firebird!
RSS Newsletter
Home About Firebird Documentation Downloads Community Support Development Case Studies Back to Top
This site and the pages contained within are Copyright © 2000-2018, Firebird Project. Firebird® is a registered trademark of Firebird Foundation Incorporated. Developed by DQ Team.